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 The next several sections introduce C#’s 
LINQ (Language Integrated Query) 
capabilities.  

 LINQ allows you to write query expressions, 
similar to SQL queries, that retrieve 
information from a wide variety of data 
sources, not just databases.  

 We use LINQ to Objects in this section to 
query arrays and Lists, selecting elements 
that satisfy a set of conditions—this is 
known as filtering.  
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 Repetition statements that filter arrays focus on the 
process of getting the results—iterating through 
the elements and checking whether they satisfy the 
desired criteria.  

 LINQ specifies the conditions that selected 
elements must satisfy. This is known as declarative 
programming—as opposed to imperative 
programming (which we’ve been doing so far) in 
which you specify the actual steps to perform a 
task.  
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 The next several statements assume that the integer array 

 int[] values = { 2, 9, 5, 0, 3, 7, 1, 4, 8, 5 };  

is declared. The query  

 var filtered = 
    from value in values 
    where value > 4      
    select value;         

specifies that the results should consist of all the ints in the 
values array that are greater than 4 (i.e., 9, 5, 7, 8 and 5). It 
does not specify how those results are obtained—the C# 
compiler generates all the necessary code automatically, 
which is one of the great strengths of LINQ.  
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The from Clause and Implicitly Typed Local Variables 

A LINQ query begins with a from clause, which 
specifies a range variable (value) and the data 
source to query (values).  

The range variable represents each item in the data 
source (one at a time), much like the control variable 
in a foreach statement. We do not specify the range 
variable’s type.  
Implicitly typed local-variables enable the compiler 
to infer a local variable’s type based on the context 
in which it’s used.  
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The var Keyword and Implicitly Typed Local Variables 

 You can also declare a local variable and let the compiler infer the 
variable’s type based on the variable’s initializer. To do so, the var 
keyword is used in place of the variable’s type when declaring the 
variable. Consider the declaration 

 var x = 7;  

 Here, the compiler infers that the variable x should be of type int, 
because the compiler assumes that whole-number values, like 7, are 
of type int.  

 Similarly, in the declaration  

 var y = -123.45;  

the compiler infers that y should be of type double, because the 
compiler assumes that floating-point number values, like -123.45, are 
of type double 
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The where Clause 

If the condition in the where clause evaluates to 
true, the element is selected—i.e., it’s included in the 
results.  

An expression that takes an element of a collection 
and returns true or false by testing a condition on 
that element is known as a predicate. 

The select Clause 

For each item in the data source, the select clause 
determines what value appears in the results. A LINQ 
query typically ends with a select clause. 
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Iterating Through the Results of the LINQ Query 
The foreach statement  

 foreach ( var element in filtered ) 
    Console.Write( " {0}", element );
  
displays the query results.  

A foreach statement can iterate through the 
contents of an array, collection or the results of a 
LINQ query, allowing you to process each element in 
the array, collection or query.  

The preceding foreach statement iterates over the 
query result filtered, displaying each of its items.  
 

©1992-2012 by Pearson Education, Inc. 

All Rights Reserved. 



The orderby Clause 

 The orderby clause sorts the query results in ascending 
order. The query 

 var sorted = 
    from value in values 
    orderby value        
    select value;         

sorts the integers in array values into ascending order and 
assigns the results to variable sorted.  

To sort in descending order, use  descending in the orderby 
clause, as in 

 orderby value descending         

 An ascending modifier also exists but isn’t normally used, 
because it’s the default.  
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 The following two queries generate the same results, but in 
different ways: 

      var sortFilteredResults = 
         from value in filtered   
         orderby value descending 
         select value;            

      var sortAndFilter = 
         from value in values     
         where value > 4          
         orderby value descending 
         select value;             
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 The first uses LINQ to sort the results of the filtered query 
presented earlier in this section.  

 The second query uses both the where and orderby clauses.  

 

An Aside: Interface IEnumerable<T> 

 foreach iterates over any so-called IEnumerable<T> object, 
which just happens to be what a LINQ query returns. 
IEnumerable<T> is an interface that describes the 
functionality of any object that can be iterated over and thus 
offers methods to access each element.  
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 LINQ can be used with most data types, including strings and 
user-defined classes. 

 The query result’s Any method returns true if there’s at least 
one element, and false if there are no elements.  

 The query result’s First method returns the first element in 
the result.  

 You should check that the query result is not empty before 
calling First. 

 LINQ defines many more extension methods, such as Count, 
which returns the number of elements in the results.  

 The Distinct extension method removes duplicate 
elements, causing all elements in the result to be unique. 
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 The syntax 

 new { e.FirstName, Last = e.LastName }  

creates a new object of an anonymous type (a type with no 
name), which the compiler generates for you based on the 
properties listed in the curly braces ({}).  

 In this case, the anonymous type consists of properties for 
the first and last names of the selected Employee.  

 The LastName property is assigned to the property Last in 
the select clause.  

 This is an example of a projection—it performs a 
transformation on the data. 
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 You can use LINQ to Objects to query Lists just as arrays.  

 LINQ’s let clause allows you to create a new range variable. 
 Useful if you need to store a temporary result for use later in the LINQ 

query.  

 Typically, let declares a new range variable to which you assign the result 
of an expression that operates on the query’s original range variable.  

 string method ToUpper converts each item to uppercase, 
then stores the result in the new range variable 
uppercaseString. 

 The where clause uses string method StartsWith to 
determine whether uppercaseString starts with the 
character "R". 
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 deferred execution 
 the query executes only when you access the results—such 

as iterating over them or using the Count method—not 
when you define the query.  

 Allows you to create a query once and execute it many 
times.  

 Any changes to the data source are reflected in the results 
each time the query executes. 

 C# has a feature called collection 
initializers, which provide a convenient 
syntax (similar to array initializers) for 
initializing a collection.  
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 LINQ to SQL enables you to access data in 
SQL Server databases using the same LINQ 
syntax introduced in the previous section.  

 You interact with the database via classes 
that are automatically generated from the 
database schema by the IDE’s LINQ to SQL 
Designer.  
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 For each table in the database, the IDE 
creates two classes: 
 A class that represents a row of the table. LINQ 

to SQL creates objects of this class—called row 
objects—to store the data from individual rows 
of the table. 

 A class that represents the table: LINQ to SQL 
creates an object of this class to store a 
collection of row objects that correspond to all 
of the rows in the table. 
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 Relationships between tables are also 
taken into account in the generated 
classes: 

 In a row object’s class, an additional property is 
created for each foreign key.  

 In the class for a row object, an additional 
property is created for the collection of row 
objects with foreign-keys that reference the row 
object’s primary key.  
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IQueryable Interface 

LINQ to SQL works through the IQueryable 
interface, which inherits from the IEnumerable 
interface.  

When a LINQ to SQL query on an IQueryable 
object executes against the database, the 
results are loaded into objects of the 
corresponding LINQ to SQL classes for 
convenient access in your code. 
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 The IDE provides visual programming 
tools and wizards that simplify 
accessing data in applications. These 
tools 

 establish database connections  

 create the objects necessary to view and 
manipulate the data through Windows 
Forms GUI controls—a technique known as 
data binding. 
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 All of the controls in this GUI are 
automatically generated when we drag a 
data source that represents the Authors 
table onto the Form in Design view.  

 The BindingNavigator is a collection of 
controls that allow you to navigate through 
the records in the DataGridView that fills 
the rest of the window.  

 The BindingNavigator controls also allow 
you to add records, delete records and save 
your changes to the database.  
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Step 1: Creating the Project 

Create a new Windows Forms Application named 
DisplayTable.  

Change the name of the source file to 
DisplayAuthorsTable.cs.  

The IDE updates the Form’s class name to match the 
source file.  

Set the Form’s Text property to Display Authors 
Table. 
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Step 2: Adding a Database to the Project and 
Connecting to the Database 
To interact with a database, you must create a 
connection to the database.  

 In Visual C# 2010 Express, select View > Other 

Windows > Database Explorer to display the Database 

Explorer window. If you’re using a full version of 
Visual Studio, select View > Server Explorer to display 
the Server Explorer.  

 From this point forward, we’ll refer to the Database 
Explorer. If you have a full version of Visual Studio, 
substitute Server Explorer for Database Explorer in the 
steps. 
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 Click the Connect to Database icon at the 
top of the Database Explorer.  

 If the Choose Data Source dialog appears, 
select Microsoft SQL Server Database File from 
the Data source: list.  

 If you check the Always use this selection 
CheckBox, the IDE will use this type of 
database file by default when you connect to 
databases in the future.  

 Click Continue to display the Add Connection 
dialog. 
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 In the Add Connection dialog, the Data 
source: TextBox reflects your selection 
from the Choose Data Source dialog.  

 You can click the Change… Button to select a 
different type of database.  

 Next, click Browse… to locate and select the 
Books.mdf file in the Databases directory 
included with this chapter’s examples.  

 You can click Test Connection to verify that the 
IDE can connect to the database through SQL 
Server Express. Click OK to create the 
connection. 
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Step 3: Generating the LINQ to SQL classes 
Right click the project name in the Solution Explorer and 

select Add > New Item… to display the Add New Item dialog.  

Select the LINQ to SQL Classes template, name the new 
item Books.dbml and click the Add button. The Object 

Relational -Designer window will appear.  

You can also double click the Books.dbml file in the 
Solution Explorer to open the Object Relational 

Designer. 
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 Expand the Books.mdf database node in 
the Database Explorer, then expand the 
Tables node.  
 Drag the Authors, Titles and 
AuthorISBN tables onto the Object 
Relational Designer.  
 The IDE prompts whether you want to 
copy the database to the project directory. 
Select Yes.  
 Save the Books.dbml file.   
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Step 1: Adding the Author LINQ to SQL Class as a 
Data Source 
Select Data > Add New Data Source… to display the 
Data Source Configuration Wizard.  
The LINQ to SQL classes are used to create objects 
representing the tables in the database, so we’ll use 
an Object data source.  

In the dialog, select Object and click Next >. Expand 
the tree view as shown in  and ensure that Author is 
checked. An object of this class will be used as the 
data source.  

Click Finish.  
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Step 2: Creating GUI Elements 

Switch to Design view for the 
DisplayAuthorsTable class.  

Click the Author node in the Data Sources 
window—it should change to a drop-down list.  
Open the drop-down by clicking the down 
arrow and ensure that the DataGridView option 
is selected—this is the GUI control that will be 
used to display and interact with the data. 

Drag the Author node from the Data Sources 
window onto the Form in Design view.  
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Step 3: Connecting the BooksDataContext to the 
authorBindingSource 
The final step is to connect the BooksDataContext 
to the authorBindingSource (created earlier in this 
section), so that the application can interact with the 
database.  
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Step 4: Saving Modifications Back to the Database 

 By default, the BindingNavigator’s Save Data 
Button is disabled. To enable it, right click the 
icon and select Enabled.  

 Double click the icon to create its Click event 
handler. 
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Step 5: Configuring the Database File to Persist 
Changes  

To persist changes for all executions, select the 
database in the Solution Explorer and set the Copy to 

Output Directory property in the Properties window to 
Copy if newer. 
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The Display Query Results application allows the user 
to select a query from the ComboBox at the bottom of 
the window, then displays the results of the query. 
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Step 1: Creating the Project 

First, create a new Windows Forms Application named 
DisplayQueryResult. Rename the source file to 
TitleQueries.cs. Set the Form’s Text property to 
Display Query Results. 

Step 2: Creating the LINQ to SQL Classes 

Follow the steps in  to add the Books database to 
the project and generate the LINQ to SQL classes. 
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Step 3: Creating a DataGridView to Display the Titles 
Table 

Follow Steps 1 and 2 in Section 18.8.2 to create the 
data source and the DataGridView.  

Select the Title class as the data source, and drag 
the Title node from the Data Sources window onto 
the form. 
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 Step 4: Adding a ComboBox to the Form 

 In Design view, add a ComboBox named 
queriesComboBox below the DataGridView on the 
Form.  

 Set the ComboBox’s Dock property to Bottom and the 
Data-GridView’s Dock property to Fill. 

 Add the names of the queries to the ComboBox.  

 Open the ComboBox’s String Collection Editor by right 
clicking the ComboBox and selecting Edit Items.  

 You can also access the String Collection Editor from the 
smart tag menu.  
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 In the String Collection Editor, add the following three 
items to queriesComboBox—one for each of the queries 
we’ll create: 
 All titles 

 Titles with 2008 copyright 

 Titles ending with "How to Program" 
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 Next you must write code that executes the 
appropriate query each time the user chooses a 
different item from queriesComboBox.  
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